Posts by DesertHare

    Anyone else noticing slow transfer times between you and the game? I'm getting serious lag times of 30-60 seconds opening and closing a task window. Example.....When transferring resources it may take as long as a minute to complete for each resource. My internet speed is good and my ping is in the single digits(Also I've cleared my browser too.). This doesn't occur on Desert-Operations, just Wargame1942(Alpha). Even the initial loading of the game takes way longer than usual.


    Hello....I'm Deserthare and I've been playing since Sept 2010. I generally log-on in the mornings, and I check-in towards the evening. I started playing because the game took no physical skill ;). Previously I was playing FPS, but I could see I was loosing my reflexes. The only time you need speed here is when there are rare resources available. Anyone can play this game and that's what I like about it. Although some are gone now and some have quit playing......I have made many friends along the way. :thumbup: (AND that's a good thing!)

    Hello....I'm Deserthare and I've been playing since Sept 2010. I generally log-on in the mornings, and I check-in towards the evening. I started playing because the game took no physical skill ;). Previously I was playing FPS, but I could see I was loosing my reflexes. The only time you need speed here is when there are rare resources available. Anyone can play this game and that's what I like about it. Although some are gone now and some have quit playing......I have made many friends along the way. :thumbup: (AND that's a good thing!)